Cisco NFVIS Software Flaw

Cisco has released an update to the Enterprise NFV Infrastructure Software (NFVIS) that addresses several security flaws found by researchers.

The purpose of the solution is to determine whether or not network services can be virtualized so that virtual network functions (VNFs) can be managed easily.

The security update shipped by Cisco recently contain three flaws, and here they are:-

Cisco Enterprise NFVIS Flaw

Among these three vulnerabilities, two flaws were rated critical and one is rated high severity. Here an attacker can exploit these vulnerabilities to run arbitrary commands with root privileges or even escape the guest VM as well to have fully taken over the NFVIS hosts.

The critical vulnerability is labeled as CVE-2022-20777 with a CVSS score of 9.9 and this flaw affects the Next-Gen Input/Output feature of Enterprise NFVIS.

Insufficient guest restrictions lead to CVE-2022-20777 and enable unauthenticated attackers to escape a guest VM. In the case of low complexity attacks, the attackers are also able to gain root-level access to the host without engaging the user in the process.

Flaw Profiles

  • CVE ID: CVE-2022-20777
  • Summary: An issue with insufficient guest restrictions that allows an authenticated, remote attacker to escape from the guest VM to gain unauthorized root-level access to the NFVIS host.
  • CVSS Score: 9.9
  • Severity: Critical
  • CVE ID: CVE-2022-20779
  • Summary: An improper input validation flaw that permits an unauthenticated, remote attacker to inject commands that execute at the root level on the NFVIS host during the image registration process.
  • CVSS Score: 8.8
  • Severity: High
  • CVE ID: CVE-2022-20780
  • Summary: A vulnerability in the import function of Cisco Enterprise NFVIS that could allow an unauthenticated, remote attacker to access system information from the host on any configured VM.
  • CVSS Score: 7.4
  • Severity: Medium

Here’s what Cisco stated:-

“This vulnerability is due to the resolution of external entities in the XML parser. An attacker could exploit this vulnerability by persuading an administrator to import a crafted file that will read data from the host and write it to any configured VM.”

Recommendation

Currently, there is no workaround is available for these flaws which means to address these security vulnerabilities company released security updates are a must.

Moreover, its infrastructure software’s default configuration is also affected by security defects, so customers should update to a fixed version immediately.

You can follow us on Linkedin, TwitterFacebook for daily Cybersecurity and hacking news updates.

Posted by Charlie